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1Introduction to
PS/Workshop
PS/Workshop is a Parasolid prototyping tool and model viewer that makes 
prototyping Parasolid-powered applications and viewing XT files a simple task in 
Windows NT. 

As well as providing high performance visualization of XT files, PS/Workshop has 
an extensible architecture that lets you create add-on modules. These modules 
give you access to the full range of Parasolid functionality, and can be developed 
easily using the PS/Workshop Wizard in Microsoft Visual Studio. For more 
information on developing your own modules for use with PS/Workshop, see the 
PS/Workshop Developer Guide.

1.1 Installing and running PS/Workshop
PS/Workshop can be found on the Parasolid Software for PC Platforms CD-
ROM. To install PS/Workshop:
� Place the Parasolid Software for PC Platforms CD-ROM in your CD-ROM 

drive, while holding down the Shift key to override the CD auto-run.
� Use Windows Explorer to browse to the PSWORKSHOP folder on the CD-

ROM.
� Double-click the file PSWORKSHOP.EXE and follow the on-screen 

instructions.

To run PS/Workshop, click on the Windows Start button and choose 
Programs > Parasolid > PSWorkshop > PSWorkshop.

1.2 The PS/Workshop window
PS/Workshop has a multi-document interface, enabling you to open several files 
at once. Figure 1–1 shows PS/Workshop with four separate files open.
PS/Workshop V2.1 User Guide 5
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Figure 1–1 The PS/Workshop window

In common with many other Windows applications, PS/Workshop contains a 
toolbar that contains buttons giving you quick access to common tasks. This 
toolbar can be docked against any edge of the PS/Workshop window, or left as a 
free-floating window in its own right. To move the toolbar from its current position, 
just click and drag its handle. To remove the toolbar altogether, choose 
View > Toolbar. Choose the same command to display it again.
PS/Workshop also contains a status bar that is used to display messages, such 
as short descriptions of a highlighted menu command. To turn the status bar on 
or off, choose View > Status Bar.

Status bar

Toolbar Menus

Open documents

Current document
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PS/Workshop contains a number of menus, described below.

� The File menu contains commands for manipulating and opening XT files. 
See Chapter 2, “Handling Files”.

� The Edit menu contains commands that let you control the colors of entities 
in the model, and which entities are selected. See Chapter 4, “Editing 
Models”.

� The View menu contains commands to change the way that the current 
model is displayed. See Chapter 3, “Viewing Models”

� The Tools menu is used to configure different options in PS/Workshop. See 
Chapter 5, “Setting Options”.

� The Help menu gives you access to online versions of the PS/Workshop 
documentation.

If any modules have been loaded in PS/Workshop, other menus may be 
available.

� Some modules may contain online help that you can access from the 
module’s user interface. 

� Printable documentation for each module can be found in the Help folder of 
the PS/Workshop installation folder, and from the PSWorkshop item on the 
Windows Start menu. You need Adobe Acrobat Reader to be able to read or 
print this documentation – see http://www.adobe.com/ for information 
on how to obtain this if you do not already have it.

To find out how to load a module in PS/Workshop, see Chapter 6, “Loading 
Modules”.

Note: You can find out the version of PS/Workshop and the build of Parasolid 
that PS/Workshop is using by choosing Help > About PS/Workshop.
PS/Workshop V2.1 User Guide 7
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
2.1 Introduction
The File menu in PS/Workshop contains commands for opening, closing, and 
managing files. A number of these commands are also available on the toolbar. 
This chapter describes how to use these commands.

2.2 Opening and closing files
Click  or choose File > Open to open a file and read the content into 
PS/Workshop. Valid file types and extensions are shown below. You can load 
both binary and text-based Parasolid files, as well as PS/Workshop V1 modules. 

When a Parasolid model is loaded, it is displayed in PS/Workshop. To close the 
file without exiting PS/Workshop, choose File > Close.
When a PS/Workshop V1 module is loaded a message indicates the success or 
failure of the loading of the DLL. If successful, the module can be used on 
documents subsequently opened. 

File contents Type Extensions
Parasolid Model text .x_t, .xmt_txt 
Parasolid Model binary .x_b, .xmt_bin 
PS/Workshop V1 module binary .dll 

Note: Functionality for loading V1 modules is provided for backward 
compatibility only. See Chapter 6, “Loading Modules” for more information on 
loading modules.
PS/Workshop V2.1 User Guide 9
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2.3 Loading part data
PS/Workshop also contains commands that let you load model data into a file 
that is already open.

� Choose File > Import to load parts from a file and add them to the current 
document.

� Choose File > Combine All Parts to combine all of the currently open parts 
to make a single, new document.

2.4 Saving files
Click  or choose File > Save to save any changes you have made to the 
current document. 

Choose File > Save As to save the file under a different name and, optionally, in 
a different format. Choose a new filename and format (if desired) in the dialog 
box that opens. All of the following formats are supported:

2.5 Printing files
There are three commands that let you print documents and control the 
appearance of the printed output. 

� Click  or choose File > Print to print the current view of the active 
document. This command displays the printer dialog box for your system. 

� If you want to see a preview of the image before printing it, choose 
File > Print Preview.

� Choose File > Print Setup to set up the default printer for PS/Workshop.
To save printer resources you are advised to set the background color to clear. 
See Section 4.3, “Editing colors”, for details. 

Format File extension
Parasolid text *.x_t 
Parasolid binary *.x_b 
RealityWave *.xgl 
Windows bitmap *.bmp 
Windows enhance metafile *.emf 
JPEG files *.jpg 
10 PS/Workshop V2.1 User Guide



3
3Viewing Models

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
3.1 Introduction
This chapter describes the different ways that you can change the way a model 
is viewed in PS/Workshop. It describes how you can alter the direction and scale 
with which a model is viewed, and how you can alter the appearance of the 
model itself by using different types of view. 

3.2 Altering view direction and scale
PS/Workshop offers a wide variety of tools to alter the direction from which a 
model is viewed, or the size of the image. Many of these tools are available 
directly from the toolbar.

3.2.1 Changing the direction of view
The following tools are available to alter the position that a model is viewed from:

Tool Description
Rotate To rotate the model, click  or choose View > Modify > Rotate. 

Click and hold down the mouse button and move the mouse to 
rotate the model. All view modes, Wireframe, Wireframe plus 
silhouettes, Hidden Line and Shaded, are supported. View 
dependent silhouette calculation is suspended while the view is 
changing. It is recomputed when the mouse button is released.

Pan To pan (scroll the current view of) the model, click  or choose 
View > Modify > Rotate. Click and hold down the mouse button 
and move the mouse to pan the model. 
PS/Workshop V2.1 User Guide 11
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3.2.2 Making the image smaller or larger
The following tools let you alter the size of the image in PS/Workshop:

Figure 3–1 Selecting a rectangular area to zoom in to

Tool Description
Zoom To zoom in and out of the model, click  or choose View 

> Modify > Zoom. To zoom in (make the image larger), click 
and hold the mouse button while moving the mouse up. To 
zoom out (make the image smaller), click and hold the 
mouse button while moving the mouse down. 

Fit to Screen To fit the entire model in the current window, click  or 
choose View > Modify > Zoom to Fit. Select this icon to 
change the scale factor of the view so that the model fills the 
window in which it is displayed. 

Zoom to Window To zoom in to a specific area of a document, click 
.Define the area of the document you want to view by 

clicking and holding down the mouse button in the top left 
corner and dragging the mouse to the bottom right corner. 
This zooms the display such that the area of the selected 
rectangle fills the window.

Note: When  is selected, you cannot select any entities in the document. 
See Section 4.2, “Selecting entities”, for information about selecting entities.

1. Click and hold 
in top left of 
rectangular area

2. Drag mouse to 
bottom right of 
rectangular area 
and release
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .Altering the appearance of the image
3.2.3 Using standard views
A number of standard views are provided as menu commands in PS/Workshop. 
By choosing the relevant command in the View > Standard Views submenu, you 
can switch instantly between the following view directions:

� Isometric
� Front
� Back
� Top
� Bottom
� Left
� Right

3.3 Altering the appearance of the image

3.3.1 Altering the line width of edges
You can use the commands in the View > LineWidth submenu to change the 
width of lines used to display edges in a model. Choose any value from 1 (the 
default) to 5.

3.3.2 Altering the way the image is rendered
PS/Workshop provides a number of different ways of rendering a model on the 
screen. These are illustrated in Figure 3–2. If a part has a color attribute 
attached, then that color is used in the rendered image. Otherwise, the default 
body color, as specified in the PS/Workshop Options dialog, is used. 

These colors, together with the document’s background color, can be edited as 
described in Section 4.3, “Editing colors”. Any model colors set within 
PS/Workshop are saved back as attributes to the model.
PS/Workshop V2.1 User Guide 13
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The following modes are provided in PS/Workshop:

Mode Description
Wireframe Click  or choose View > Display > Wireframe to display the 

document in wireframe mode. This mode renders every edge on 
the model on the screen. 

Wireframe + 
Silhouettes

Click  or choose View > Display > Wireframe + Silhouettes 
to display the document in wireframe silhouette mode. 
Silhouette edges are edges that are implied by the view, rather 
than being real edges in the model itself. Their locations depend 
upon the view parameters and are computed as the view 
changes. 

Hidden Line Click  or choose View > Display > Hiddenline to display the 
document in hidden line mode. This mode shows only those 
parts of real and silhouette edges that can be seen from the 
current view direction. Any part of an edge that is obscured by 
some other part of the model is not drawn. The results depend 
upon the view parameters and are computed as the view 
changes. 

Shaded Click  or choose View > Display > Shaded to display the 
current model in shaded mode, as shown in Figure 3–2. Shaded 
mode can also be combined with either Wireframe or Wireframe 
+ Silhouettes modes. These combined modes are known as 
Dual Display Modes.
14 PS/Workshop V2.1 User Guide
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Figure 3–2 Wireframe, wireframe + silhouettes, hidden line, and shaded modes

3.3.3 Re-rendering the view
Zooming in on a portion of the model can produce a coarse screen image, 
especially if the model in the viewing area is curved. Click  to recompute a 
smooth view for the current view parameters. 

Wireframe Wireframe + 
silhouettes

Hidden line Shaded
PS/Workshop V2.1 User Guide 15
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
4.1 Introduction
This chapter describes some of the tools that PS/Workshop provides to let you 
edit a model. It also describes how to select entities in a model: sometimes 
editing functions will only work on selected entities in a model.

4.2 Selecting entities
Many editing functions – especially those provided by PS/Workshop modules – 
require you to select one or more entities in the model. Once selected, the editing 
function operates solely on the selected entities.

To select entities in a model, click  on the toolbar to enter selection mode. 
When this button is selected, you can select combinations of bodies, faces, 
edges and vertices in the current view by clicking on them. 

If you click  to leave selection mode, any selected entities are deselected.

Selected entities are displayed in the color specified in the Options dialog. See 
Chapter 5, “Setting Options”, for details.

Note: Many PS/Workshop modules also provide functionality that lets you edit 
a model. For example, a given module might let you add blends to a model. 
This chapter does not describe the functionality of individual modules: see the 
online documentation for each module, as described in Section 1.2.

To pick … Do this …
a face Pick within the area of a face, well away from a 

boundary. 
an edge Place the cursor along the edge and away from a 

bounding vertex. 
an item that is obscured 
by other parts of model

Use the Rotate  and Zoom  buttons to 
change the view so that it is easier to pick the 
desired item. 
PS/Workshop V2.1 User Guide 17
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4.2.1 Choosing which entities can be selected
You can choose which topological types you want to be able to select when in 
selection mode from the pull-down menu immediately next to the  button. Click 
on the arrow to display the menu, and then choose a topological entity to toggle 
the ability to select that entity. You can choose to select either

� any mutually inclusive combination of faces, edges, and vertices, or
� bodies
By default, you can select faces, edges and vertices. 

Figure 4–1 Choosing which entity types can be selected

The set of entity types that can be selected at any time is referred to as the 
selection filter.

4.2.2 Quick entity selection
The following commands are available to quickly select or deselect entities in a 
model. In each case, only those entity types currently in the selection are 
selected when using these commands.

4.3 Editing colors
PS/Workshop provides a number of commands for changing the color of different 
parts of a model. These commands are all available in the Edit > Colour menu.

Note: Selection mode is not available when you have chosen the Zoom to 
Window  tool.

Command Description
Edit > Select All Selects all the entities in the model.
Edit > Unselect All Deselects all the entities in the model.
Edit > Invert Selection Inverts the current selection: those entities that are 

selected become deselected, and those that are not 
selected become selected.
18 PS/Workshop V2.1 User Guide
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4.4 Editing transparency of faces
You can use the commands in the View > Transparency submenu to change the 
transparency of any selected faces in the model. Transparency is expressed as 
a percentage: 0% is opaque, 100% is clear.

Command Description
All Entities Change the color of all entities in the document.
Selected Entities Change the color of all selected entities in the 

document. 
Background Change the background color of the current 

document.
Edges In Dual Display Modify the color used to display edges in Dual Display 

Modes (i.e. when  or  are switched on at the 
same time as ).

Selection Colour Modifies the default selection color for entities. You 
can also modify this color in the Options dialog. See 
Chapter 5, “Setting Options”, for details.
PS/Workshop V2.1 User Guide 19
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5Setting Options

. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
5.1 Introduction
This chapter describes the range of options that you can set in PS/Workshop. 
These options are used by default on any document that you subsequently 
open.You can set the following groups of options:
� General options – see Section 5.2
� Default colors – see Section 5.3
� Graphics options – see Section 5.4
� Transmit and receive options – see Section 5.5
� Default file locations – see Section 5.6
� Symmetric multi-processing (SMP) options – see Section 5.7
� Module loading – see Section 5.8

Each group of options is available in a separate tab in the Options dialog. Choose 
Tools > Options to open this dialog.

5.2 General
The General tab lets you specify the sensitivity of mouse controls for the rotate, 
pan and zoom modes in PS/Workshop. Move any slider to the right to increase 
the sensitivity for that mode.
PS/Workshop V2.1 User Guide 21
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Figure 5–1 General options

5.3 Default colors
The Default Colours tab lets you specify the default colors used for selected 
entities, bodies, the document background, and edges when in Dual Display 
Modes. Click on the color you want to change and choose a new color in the 
Color dialog that opens.

Figure 5–2 Default color options
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5.4 Graphics
The Graphics tab is for specifying how certain graphic properties are displayed in 
PS/Workshop. 

� The Hidden Line mode panel lets you choose to display hidden lines in 
Hidden Line mode. You can also choose the color to display hidden lines in, 
and whether hidden lines should be solid, dashed, or dotted.

� The View panel lets you control how models are viewed in PS/Workshop. 
When Display axes is turned on, a small triad indicating the direction of the 
x, y, and z axes appears in the bottom right hand corner of each open 
document. You can choose which view is used when opening a document 
from the Initial view style list.

Figure 5–3 Graphics options

Click Restore Defaults to restore the default settings for each of the options on 
this tab.
Click Advanced Graphics to open the Advanced Graphics dialog, shown in 
Figure 5–4.

� The Shaded mode panel lets you control how facets are displayed in 
Shaded mode. You can display facets as shaded, wires, or points. 
Additionally, when viewing shaded facets, you can choose whether each 
facet should appear flat or smooth.

� The Facet Strips panel lets you control the output of facet strips in Shaded 
mode. If Output facet strips is turned on, then facet strips are output. If, in 
PS/Workshop V2.1 User Guide 23
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addition, Facet style in the Shaded mode panel is set to Wire, you can 
control the appearance of facet strips in the document window: 
� Click the Strip color to choose which color facet strips are displayed in.
� Turn on Display strip outline only if you just want to see the edge of 

each facet strip, but not the facet detail within each strip.

Figure 5–4 Advanced graphics options

5.5 Transmit and receive
The Transmit/Receive tab lets you specify transmit and receive options. 
� Select the Parasolid version that you want to use for saving part files in the 

Transmit Options area. 
� Specify whether to reduce assemblies to their constituent parts when 

opening documents in the Receive Options area.

Figure 5–5 Transmit/receive options
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5.6 Default file locations
The File Locations tab lets you specify default folders for schema, module and 
help Files. To change a default location, select it in the File Types list, click 
Modify, and browse to a new location in the dialog that opens.

To load PS/Workshop V1 modules automatically when starting PS/Workshop, put 
a tick in the check-box. See Section 6.1, “PS/Workshop V1 modules” for more 
details.

Figure 5–6 File location options

5.7 Symmetric multi-processing (SMP)
The SMP tab lets you turn Parasolid SMP on or off. If your computer only has a 
single processor, you can ignore this option.
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Figure 5–7 SMP options

5.8 Module loading
The Add-Ins tab provides control over which COM-based modules are currently 
loaded in PS/Workshop. It also lets you manually register or remove a COM-
based module. COM-based modules can only be used with PS/Workshop V2 
and above. See Section 6.2, “PS/Workshop V2 modules”

Figure 5–8 Module options
26 PS/Workshop V2.1 User Guide



. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .Module loading
Note: This tab is only available if you choose Tools > Options when there are 
no documents open in PS/Workshop.
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
This chapter explains how modules are loaded and managed in PS/Workshop to 
provide extra functionality. There are two types of module that can be loaded into 
PS/Workshop:

� Modules that were developed for use with PS/Workshop V1.
� COM-enabled modules that were developed for use with PS/Workshop V2 

and above.
Both types of module are managed in different ways, as explained in the rest of 
this chapter.

Once a module has been loaded, a new item appears on the PS/Workshop menu 
bar that gives access to the functionality of the module.

For information on developing your own modules for use with PS/Workshop, see 
the PS/Workshop Developer Guide.

6.1 PS/Workshop V1 modules
Modules that were developed for use with PS/Workshop V1 are loaded using 
File > Open, as described in Section 2.2, “Opening and closing files”. Once a 
module has been successfully loaded, its functionality is available to any 
documents that you subsequently open, but will not be available to documents 
that were already open when the module was loaded. 
You can load a V1 module automatically when PS/Workshop is started as 
follows:

� Place the DLL file for the module in PS/Workshop’s Modules folder (by 
default, this is the Modules folder in the PS/Workshop installation folder).

� In PS/Workshop, choose Tools > Options and click the File Locations tab.
� Make sure that the “Automatically Load Modules at Start” option is ticked.
� Click OK to dismiss the Options dialog.

You can also change the location of the Modules folder from the File Locations 
tab of the Options dialog. See Section 5.6, “Default file locations”, for details. 
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6.2 PS/Workshop V2 modules
Modules developed for use with PS/Workshop V2 and above use the COM 
interface provided by PS/Workshop. As such, they need to be registered on your 
computer before PS/Workshop can recognize them. 

COM-based modules are managed using the Add-Ins tab of the PS/Workshop 
Options dialog. Choose Tools > Options to display this dialog.

This tab displays all the modules that are recognized by PS/Workshop. In order 
for a module to be recognized by PS/Workshop it needs to be registered on the 
computer. 

Figure 6–1 Managing COM-based modules

6.2.1 Registering V2 modules
Before a module is listed in the Available Add-Ins list of the Add-Ins tab, it must 
be registered. There are two ways of registering a V2 module:

� Automatically. Many V2 modules are registered automatically when they 
are installed. For instance, all the modules that are supplied with 
PS/Workshop itself are registered automatically. 

� Manually. Sometimes, you may have a module that is not registered 
automatically (for example, if you are just given a single DLL file). To register 

Note: The Add-Ins tab of the Options dialog is only available if there are no 
documents open.
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it manually, click Add in the Add-Ins tab of the Options dialog, and browse for 
the new module. After registering the module a new entry is added to the 
module list.

You may need to register a module manually if you decide you need to use a 
module having already removed it from the list of modules.

6.2.2 Loading and unloading V2 modules 
You can dynamically load and unload V2 modules from the Add-Ins tab of the 
PS/Workshop Options dialog.
� To load a V2 module, place a tick next to the module name in the Available 

Add-Ins list of the Add-Ins tab, as shown in Figure 6–1.
� To unload a module, remove the tick from the module name. The module is 

still available for you to load without having to re-register it.

Modules that are ticked in the Available Add-Ins list are also loaded automatically 
when you start PS/Workshop.

6.2.3 Removing V2 modules
You can remove a V2 module permanently from the list of modules in the Add-Ins 
tab of the Options dialog as follows:

� Display the Add-Ins tab of the Options dialog.
� Select the module you want to remove.
� Click Remove.

If you need to add a module back into the list after removing it, you will need to 
re-register it manually, as described in Section 6.2.1, “Registering V2 modules”.

Note:  Removing the module from the list does not delete the module from the 
system - it only de-registers it so that it is no longer available to PS/Workshop. 
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. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
This chapter lists known issues with the current version of PS/Workshop.

PS/Workshop has been compiled, linked and tested on Windows NT version 4.0 
with Service Pack 5. It is supported on versions of Windows NT 4.0 with Service 
Pack 3 and above. 
It has been compiled using Microsoft Visual C++ version 6.0 with Service Pack 4. 
PS/Workshop has also been tested on Windows 2000, should also run on 
Windows 98 and Windows ME although it is not officially supported on these last 
two platforms.

On certain graphics cards in 256 color mode an open part may not display 
correctly. To correct this problem switch to a higher color mode and restart 
PS/Workshop. 

Modules written for previous versions of PS/Workshop and linked to 
edsps111.lib will need to be recompiled and linked to pskernel.lib to load 
successfully 
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